GlobalProtect Uninstall Message "Uninstallation is not allowed, please contact your IT administrator!"

GlobalProtect Uninstall Message "Uninstallation is not allowed, please contact your IT administrator!"

25423
Created On 06/17/21 12:19 PM - Last Modified 04/10/23 19:01 PM


Symptom


  • GlobalProtect uninstall is not possible and fails with message: Uninstallation is not allowed, please contact your IT administrator!
User-added image
  • Once you click 'OK' a new window pops up with a different message: There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.
User-added image
 


Environment


  • GlobalProtect App for Windows


Cause


This issue can be seen when GlobalProtect Portal has configuration Allow User to Uninstall GlobalProtect App (Windows Only) set to 'Disallow'.

When GlobalProtect Agent is connecting to the Portal, it will fetch Agent configuration. In PanGPA.log file one can see: 
HOW TO COLLECT LOGS FROM GLOBALPROTECT CLIENTS
<agent-config name="agent-config">
		<save-user-credentials>1</save-user-credentials>
		<portal-2fa>no</portal-2fa>
                <snip>
		<uninstall>disabled</uninstall>
                <snip>


Resolution


  1. GUI:  Network > GlobalProtect > Portals >  <GlobalProtect-portal-config> > Agent > <agent-config> -> App tab. 
  2. Change Allow User to Uninstall GlobalProtect App (Windows Only) to 'Allow
User-added image
  1. From the GlobalProtect Client, Refresh the connection in order for the GlobalProtect Agent to fetch the new configuration from the Portal. 
  2. Then try to uninstall GlobalProtect


Additional Information


Allow User to Uninstall GlobalProtect App - Specifies whether users are allowed to uninstall the GlobalProtect app and, if so, what—if anything—they must do before they can uninstall the app:
  • Allow — Allow any user to uninstall the GlobalProtect app as needed.
  • Disallow — Do not allow end users to uninstall the GlobalProtect app.
  • Allow with Password — Enforce a password to uninstall the GlobalProtect app. This option requires the user to enter and confirm a password before they can proceed with uninstallation. You can provide the password through email or as a posting on your organization’s website.


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000001VfGCAU&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language