Dynamic Agent is failing to install antivirus package with "Failed to upgrade Antivirus package to version <unknown version>"
12635
Created On 04/30/21 03:34 AM - Last Modified 06/01/23 03:05 AM
Symptom
- Dynamic Agent is failing to install antivirus package with "Failed to upgrade Antivirus package to version <unknown version>".
- The log file "upgradelog_err_sig_av" shows "/bin/cp: writing `/opt/pancfg/mgmt/updates/newav/virus_signatures.db': No space left on device".
- When Dynamic Agent is failing to install antivirus package for some reason, the message for debugging is written to "upgradelog_err_sig_av". "upgradelog_err_sig_av" will be created when install antivirus package failure by Dynamic Agent happens.
Environment
- PANOS-8.1 and later.
- Customer is seeing an issue where Dynamic Agent is failing to install antivirus package with "Failed to upgrade Antivirus package to version <unknown version>".
Cause
- The message "/bin/cp: writing `/opt/pancfg/mgmt/updates/newav/virus_signatures.db': No space left on device" means that there is no room to store the data to install the antivirus package because old-content cache data and unused anti-virus signature packages.
- The customer can delete old-content cache data and unused anti-virus signature packages with "delete content cache old-content" and "delete anti-virus update <unused anti-virus>" commands.
Resolution
- Please try deleting old-content cache data and unused anti-virus signature packages with "delete content cache old-content" and "delete anti-virus update <unused anti-virus>" and monitor to see if Dynamic Agent is failing to install antivirus package or not.
Additional Information
- When Dynamic Agent is failing to install content package for some reason, the message for debugging is written to the log "upgradelog_err_content". "upgradelog_err_content" will be created when install content package failure by Dynamic Agent happens.