Netflow logs are not being sent

Netflow logs are not being sent

9608
Created On 03/23/21 13:40 PM - Last Modified 04/29/24 18:04 PM


Symptom


You verify reachability to the Netflow server and can see that the counters for Netflow statistics are incrementing, however there are no hits on the security policy and the collector doesn't receive any data.

> debug log-receiver netflow statistics
> debug dataplane netflow statistics (for PA-7000/PA-5200/PA-3200 series)

 Netflow Statistics
--------------------------------------------------------------------------------
          Template Config           Last Refreshes            Pkts Sent (errors)
--------------------------------------------------------------------------------
Server Profile : pantaclab_netflow_server_profile
          30 min/20 pkts          28 min/8 pkts                    3223 (0)
Total Netflow packets exported : 3223 (errors 0)


Tip: To clear the counters above, you can run this command:

> debug log-receiver netflow clear


Environment


All firewall platforms

Cause


Under Device Tab > Netflow > Netflow Server Profile Netflow server IP address is set with subnet mask.

User-added image


Resolution


Do not use a subnet mask when configuring the Netflow server IP address 

Additional Information


How to configure Netflow on Palo Alto Networks Firewall:
https://docs.paloaltonetworks.com/pan-os/9-1/pan-os-admin/monitoring/netflow-monitoring/configure-netflow-exports.html

HOW TO VERIFY AND TROUBLESHOOT NETFLOW
https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000008UuYCAU&lang=en_US%E2%80%A9



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