XML API demande d’interface renvoie erreur d’accès: 404

XML API demande d’interface renvoie erreur d’accès: 404

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Created On 03/24/19 01:48 AM - Last Modified 08/20/21 20:09 PM


Symptom


XML API demande d’interface renvoie "Erreur d’accès: 404" GlobalProtect lorsque Portal est configuré sur cette interface.
L’exemple ci-dessous lors de l’exécution de la commande keygen à partir du navigateur:

curl -k -X GET 'https://192.168.168.168/api/?type=keygen&user=**LOGICMONITOR-USER**&password=**PASSWORD** 
<!DOCTYPE html> 
<html><head><title>Document Error: Not Found</title></head> 
<body><h2>Access Error: 404 -- Not Found</h2> 
<p>Can't locate document: /api/</p> 
</body> 
</html>
 


Environment


  • Palo Alto Firewall ( VM ou Hardware )
  • PAN-OS 8,0 et plus.
  • GlobalProtect Portail configuré sur la même interface de XML API demande.


Cause


XML API demande ne peut pas être envoyée à une interface qui héberge le portail Global Protect car il fonctionne sur le même URL port et le port (443).

Resolution


Si l’interface cible où XML API la demande est envoyée a activé Global protect Portal/Gateway, elle répondra à la demande sur le port XML API 4443. La commande doit spécifier le port 4443 pour réussir.

Exemple:
curl -k -X GET 'https://192.168.168.168:4443/api/?type=keygen&user=**LOGICMONITOR-USER**&password=**PASSWORD**

 


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