Error codes for Proofpoint integration with the WildFire API
13182
Created On 04/20/20 22:53 PM - Last Modified 01/20/23 19:23 PM
Symptom
- Files submitted via the Wildfire API from Proofpoint TAP may be rejected or may experience delays.
Environment
- WildFire subscribers who have integrated their Proofpoint TAP solution with the WildFire API.
Cause
Various reasons exist as to why the file submissions may experience a verdict delay. Previous issues have been addressed by engineering and now there are error codes that customers can see from their TAP management portal that identify how the Wildfire API responded to the delayed submissions. These error codes allow engineering to identify the reason for the verdict delay.
Effective February 1, 2023, all submissions from Proofpoint integration will be counted against daily WildFire API limits. Once the daily limits are surpassed, WildFire will respond to Proofpoint with error code 419: '419 Quota Exceeded'.
Resolution
Customers can check the Wildfire API reply message error codes in their Proofpoint TAP managment solution to identify the Wildfire API's response to the delayed submission. The error codes are as follows:
- 400: '400 Invalid Syntax',
- 401: '401 Invalid API key'
- 4011: '401 Please relogin',
- 4030: '403 Invalid Date',
- 4031: '403 Permission Denied',
- 404: '404 Not Found',
- 405: '405 Unsupported Method',
- 409: 'HTTP 409',
- 410: '410 Sample Gone',
- 413: '413 File Too Large',
- 417: '417 Same Verdict',
- 418: '418 Unsupport File Type',
- 419: '419 Quota Exceeded',
- 429: '429 Too Many Requests',
- 420: '420 Insufficient Arguments',
- 421: '421 Invalid Argument',
- 422: '422 Unprocessable Entities',
- 500: '500 Internal Error',
- 513: '513 File Uploaded Failed',
- 503: '503 Network Issue',
Additional Information