GlobalProtect 应用提示用户在移动设备上使用用户名和密码

GlobalProtect 应用提示用户在移动设备上使用用户名和密码

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Created On 04/10/20 03:59 AM - Last Modified 03/26/21 18:16 PM


Symptom


  • 当用户在其移动设备上启动需要连接的应用程序 VPN 时, GlobalProtect 应用会第一次安装,因此可能会发出通知,指示"需要登录"。
  • 用户启动的应用程序可能会变得无响应(例如空白屏幕),直到用户切换到 GlobalProtect 应用用户界面并输入其凭据以继续建立连接。
  • 连接建立后,应用程序变得响应 VPN 。


Environment


  • GlobalProtect 使用身份验证服务(如 RADIUS 或 LDAP
  • GlobalProtect 配置为连接到此网关的应用程序
  • 一个尼 PAN-OS
  • 任何帕洛阿尔托 Firewall 。


Cause


根据相应的移动操作系统的设计和限制,移动应用的行为可能有所不同。

GlobalProtectApp 提示用户使用用户名和密码的原因是 RADIUS LDAP 网关配置中选择的身份验证配置文件(例如使用或服务)。

身份验证协议喜欢 RADIUS 并 LDAP 经常需要用户名/密码组合。 该 GlobalProtect 应用程序将从用户处获取信息,然后提交到后端的身份验证服务器。 这种行为是有意的。

即使在后端身份验证服务器不需要用户名和密码的罕见情况下,使用(Windows/Mac)的最终用户体验也可能有所不同 PC OS ,因为借助单个登录功能, GlobalProtect 将用户名/密码组合转发到 Firewall 后端身份验证,而无需提示用户输入。


Resolution


在门户以下的客户身份验证设置中启用"保存用户凭据 GlobalProtect GUI ": 网络 GlobalProtect >>门户>(门户名称)>代理>(代理名称)>身份验证。 因此,用户只需输入其用户名/密码组合一次。

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