Cannot retrieve licenses on PAYG PA-VM instances

Cannot retrieve licenses on PAYG PA-VM instances

16374
Created On 03/18/20 05:25 AM - Last Modified 07/20/20 17:59 PM


Symptom


PA-VM deployed in AWS or Azure environments do not show the “License Management” pane to activate auth-codes or retrieve licenses from server under WebUI > Device > Licenses
 
PA-VM Support


License Tab
 
  • Check if PA-VM instance was deployed using Pay-as-you-go (PAYG) model
  • Review System logs and/or Plugin logs to check if bundle license is applied
System Logs
2020/01/31 16:29:09 info     general        general 0  VM Appliance license is installed.

pan_vm_plugin.log
2020-01-31 16:26:45.860 -0800 vm_host_init INFO: : Installing VM300_BND1 license, Product code: 6kxdw3bbmdeda3o6i1ggqt4km


Environment


  • Platform: AWS/Azure
  • PAN-OS/Plugin Version: Any
  • Deployment: New, PAYG


Cause


  • With usage based licenses also called as pay-as-you-go (PAYG) licenses, the firewall is pre-licensed and ready for use as soon as you deploy it; you do not receive an auth-code. When the firewall is stopped or terminated on the AWS or Azure console, the usage-based licenses are suspended or terminated.


Resolution


  • Register PAYG firewall on CSP portal without authcode.
  • Follow the steps below:
  1. On the Assets tab (after you log in to the Palo Alto Networks Customer Support website), click Device > Register > New Device.
  2. Select Register usage-based VM-Series models (hourly/annual) purchased from public cloud Marketplace or Cloud Security Service Provider (CSSP).
  3. Select your Cloud Marketplace vendor and Submit.
  4. Enter the Serial #, the CPU ID, and the UUID of the VM-Series firewall.
  5. Agree and Submit to accept the EULA and register the firewall.
  6. Verify that the details on the licenses you purchased are displayed on the Assets page of the support portal.


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000PP6bCAG&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language