GlobalProtect Client Credentials Are Being Cleared Even Though "Save User Credentials" Is Enabled
32637
Created On 01/30/20 02:03 AM - Last Modified 03/31/25 20:55 PM
Symptom
- When connecting with the Global Protect client, the client is prompting for username and password
- Under the Global Protect Portal -> Configs -> Authentication tab, the "Save User Credentials" is set to "Yes" (saving both username and password) or to "Save Username Only"
Environment
- Palo Alto Firewalls
- Global Protect App on Windows, Mac, or Android
Cause
- The user is clicking the "Sign Out" button to disconnect from GlobalProtect.
- By design, the "sign out" button is meant to clear the user credentials. This is expected behavior.
- When the user clicks "Sign Out", a warning is presented indicating that the saved credentials will be cleared:
- After "sign out" the user is prompted to enter credentials on the next connection attempt (credentials have been cleared):
Resolution
- The "Save User Credentials" will preserve the user credentials when the user "Disconnects" from Global Protect in "On Demand" connection method, and also when the user is reconnecting in Always-on modes.
- To preserve the user credentials, do not click the "Sign Out" button.
Mac/IOS/Android clients work the same - the GUI may look different on different clients.
Additional Information
Refer to the similar article : When is the Authentication cookie deleted from GlobalProtect app?