Unable to perform Commit due to Auto Commit stuck
29166
Created On 12/21/19 22:09 PM - Last Modified 03/20/25 23:23 PM
Symptom
Auto commit job stuck at 10% for a long time,
PA-500> show jobs all
Enqueued Dequeued ID PositionInQ Type Status Result Completed
------------------------------------------------------------------------------------------------------
2019/12/22 03:53:58 2 1 EDLRefresh QUEUED PEND 0%
2019/12/22 04:00:58 3 2 EDLRefresh QUEUED PEND 0%
2019/12/22 03:51:24 03:51:24 1 AutoCom ACT PEND 10%
- Detail of the job using command show jobs id <job-ID of auto-commit job> shows the progress of Auto Commit 10 % with status as 'ACT' and Result as 'PEND'
Enqueued Dequeued ID Type Status Result Completed
-------------------------------------------------------------------------------------------------------
2019/12/22 03:51:24 03:51:24 1 AutoCom ACT PEND 10%
Environment
- Palo Alto PA-500 Firewall.
- Any PAN-OS
Cause
- Auto Commit job should not be stuck at 10 % for more than 30 minutes
- devsrvr.log, shows an error that suggests some applications not found. One instance is as below:
Error: pan_tcomp_parse_set_app(pan_tcomp.c:3706): setapp error: application betternetvpn not found
Warning: pan_tcomp_parse_attack(pan_tcomp.c:4690): Threat: tid 47774 parsing error, ignore
Error: pan_tcomp_parse_actions(pan_tcomp.c:3937): Threat Compiler: Signature error
Error: pan_tcomp_parse_set_app(pan_tcomp.c:3706): setapp error: application betternetvpn not foundResolution
- Check whether the latest version of apps is installed on the Firewall.
- If Firewall has the latest apps version and this issue is observed, perform a "commit force" from configure mode with steps below.
> Configure
# Commit force
# exit
Commit force will re-parse and recommit the whole configuration and auto-commit will be successful.