URL Categorized as Unknown - Website Not Loading

URL Categorized as Unknown - Website Not Loading

25245
Created On 11/24/19 12:05 PM - Last Modified 04/08/25 09:37 AM


Symptom


URLs are categorized but in the URL filtering logs it shows unknown and is getting blocked.

While testing in the CLI, it'll show the URL getting categorized correctly.

CLI test


Environment


  • NGFW
  • Supported PANOS versions
  • URL Filtering


Cause


This can happen based on the following reasons:
  • Old cache files
  • Database not being updated from MP to DP
  • URL database has been corrupted

If you check URL logs under the Monitor tab, the output will look like example below, where it's showing unknown and getting blocked.

URL Logs Monitor Tab View

 


Resolution


NOTE: Allow list for URLs might not help because of old cache.

You need to clear the URL cache from the Management Plane and Data Plane. 

> delete url-database all
> clear url-cache all

After running this command, MP and DP will build new database and cache. In developer mode of browser, you will find that status codes will be 200 with green dot.

View of Developer mode showing 200 code status and green dot.



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