Encountering "Server error : Failed to change to management-only mode" when migrating from Legacy/Panorama mode

Encountering "Server error : Failed to change to management-only mode" when migrating from Legacy/Panorama mode

16522
Created On 06/22/19 17:58 PM - Last Modified 04/27/20 16:40 PM


Symptom


  • Switching to management-only mode failed due to the error of cannot switch to management-only mode; all devices must be included in log-collector-group(s).
admin@Panorama> request system system-mode management-only
Executing this command will change the system to management-only mode, logs will be removed. This will restart the system. Are you sure you want to continue? (y or n)

Server error : Failed to change to management-only mode.
cannot switch to management-only mode; all devices must be included in log-collector-group(s).

 


Environment


  • model: Panorama
  • vm-mode: VMWare ESXi
  • sw-version: 8.1.4


Cause


The panorama is not connected to any log collector

Resolution


Switching Panorama mode from “legacy” or “panorama” to “management-only” can only be successful if the requirements below are met:
  1. The current system meets or exceeds the minimum resource requirements.
  2. There is no internal/local log-collector.
  3. All device instances must be members of a log-collector-group.


Additional Information


Note: If connecting to any log collector is not an option, the workaround is, perform factory reset then switch to management-only mode

Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000PMCgCAO&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail