Receiving "500: Internal Server Error" when attempting to preview changes
61699
Created On 05/01/19 21:35 PM - Last Modified 04/19/24 20:13 PM
Symptom
When trying to view the configuration changes prior to commit using GUI: Commit > Commit to Panorama > Preview Changes, an error message "500: Internal Server Error" is displayed.
Environment
- Any Panorama.
- Any Palo Alto Firewalls.
- PAN-OS 8.1.8 or below.
- PAN-OS 9.0.1 or below.
Cause
The issue is caused due to memory errors.
Resolution
- The issue has been fixed in PAN-OS 8.1.9 and 9.0.2.
- The workaround is to restart the management server from CLI (you will get kicked out of GUI and CLI after and will need to log back in)
> debug software restart process management-server
- If GUI goes blank after logging back in try restarting the web-server from CLI, then restarting the management server again
> debug software restart process web-server
Note: If the issue happens with Panorama running version 8.1.9 and 9.0.2 and above, please do the following steps:
- Skip the provided workaround steps above
- Core and restart management server from CLI
> debug software restart core yes process management-server
- Core and restart the web-server from CLI
> debug software restart core yes process web-server
- Open a new support case for Palo Alto Networks Support to investigate.
- Generate and upload the latest tech support file on to the new support case
- Upload both core files directly to support. Refer to this link: How To Upload Core Files Directly To Support
Additional Information
The issue has been fixed under defect PAN-113614 in PAN-OS 8.1.9 and above(8.1 version) or 9.0.2 and above (9.0 version).
Note: Restarting the management server/ web-server causes all management sessions and web sessions to get disconnected. Any SSH. web and CLI sessions get disconnected and will be reconnected after the process restart is complete.