Imported Certificate Not Showing Under SSL/TLS Service Profile

Imported Certificate Not Showing Under SSL/TLS Service Profile

46776
Created On 04/25/19 16:03 PM - Last Modified 07/09/25 15:44 PM


Symptom


The certificate is imported on the firewall, but it does not show up under the SSL/TLS service profile.

Screenshot showing the certificate:
User-added image

Screenshot showing the SSL/TLS service profile not pulling the imported certificate:
User-added image


Environment


PAN-OS
Panorama


Cause


This is due to the certificate not being imported with the private key. The screenshot below shows the key missing on the certificate.
User-added image


Resolution


The private key is required for the firewall to be able to sign using the certificate. If your enterprise has its own public key infrastructure (PKI), you can import a certificate and private key into the firewall from your enterprise certificate authority (CA).
 


Additional Information


For additional information, please reference this article:
https://docs.paloaltonetworks.com/pan-os/11-1/pan-os-admin/certificate-management/obtain-certificates/import-a-certificate-and-private-key



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