Imported Certificate Not Showing Under SSL/TLS Service Profile
46766
Created On 04/25/19 16:03 PM - Last Modified 07/09/25 15:44 PM
Symptom
The certificate is imported on the firewall, but it does not show up under the SSL/TLS service profile.
Screenshot showing the certificate:
Screenshot showing the SSL/TLS service profile not pulling the imported certificate:
Environment
PAN-OS
Panorama
Cause
This is due to the certificate not being imported with the private key. The screenshot below shows the key missing on the certificate.
Resolution
The private key is required for the firewall to be able to sign using the certificate. If your enterprise has its own public key infrastructure (PKI), you can import a certificate and private key into the firewall from your enterprise certificate authority (CA).
Additional Information
For additional information, please reference this article:
https://docs.paloaltonetworks.com/pan-os/11-1/pan-os-admin/certificate-management/obtain-certificates/import-a-certificate-and-private-key