Unable to upgrade or remove GP Agent due to "The specified account already exists" error

Unable to upgrade or remove GP Agent due to "The specified account already exists" error

9738
Created On 04/06/19 00:48 AM - Last Modified 01/08/25 11:00 AM


Symptom


Issue occurs when uninstalling, removing, or upgrading GlobalProtect (GP) Agent.
Error message - "The specified account already exists."

User-added image

User-added image


Environment


  • Affects GP Agent 4.0 and 4.1
  • Windows 7 / 10


Cause


Cause due to msiexec.exe blocking the uninstall for GP Agent 4.1.2

Resolution


  1. Press Ctrl+Alt+Delete and Start the Task Manager.
  2. In the Task Manager, find any third-party msiexec programs that are currently running (for example, msiexec command line - Google Search).
  3. Select the third party installer and click End Task to stop it.
Documentation for more detailed steps:
https://docs.paloaltonetworks.com/globalprotect/4-0/globalprotect-agent-user-guide/globalprotect-agent-for-windows/fix-a-microsoft-installer-conflict


Additional Information


It can also be due to Windows .msi installer not working correctly.

To fix, download the Windows cleanup utility tool.
https://support.microsoft.com/en-us/help/17588/windows-fix-problems-that-block-programs-being-installed-or-removed


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000PLQ3CAO&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language