CSV トラフィックログのエクスポートは、PA-2000 シリーズのファイアウォールで完全にダウンロードに失敗する
Resolution
問題
csv エクスポート値の最大行が最大 (1048576) に設定されている場合、PA-2000 シリーズファイアウォールの web UI からのトラフィックログの csv エクスポートは完全にダウンロードできません。トラフィックログファイルは通常、300 mb より大きくなりますが、ダウンロードしたファイルには、合計データの一部しか含まれていません。
注:この動作は、PA-2000 シリーズのファイアウォールでのみ明らかです。
CSV エクスポート値の最大行数は、[デバイス] > [セットアップ] > [管理] > [ログとレポートの設定] で構成されています。
web ブラウザに関係なく、ダウンロードはまだタイムアウトします。IE のエラーが表示されます、"ログ .csv のダウンロードが中断されました"。Firefox では、エラーはありませんが、ダウンロードバーは問題が発生していないかのように閉じます。
問題が発生する "CSV エクスポートの最大行数" の正確なしきい値はありません。定義する要素は、CSV ファイルのサイズと、それを取得するための接続の帯域幅です。「csv エクスポートの最大行数」値を1048576の max エントリにすると、300 mb を超える csv ファイルが生成され、ダウンロードにかかる時間が長くなります。ダウンロードに6分以上かかる場合、ダウンロードした csv ファイルは csv ファイル全体の一部にすぎません。ファイルをダウンロードしているクライアントが、接続が遅いリモートサイトからのものである場合、6分間のタイムアウトにより、ダウンロードしたファイルのサイズが小さくなります。
原因
パロアルトネットワークファイアウォールの WEBUI サービスのタイムアウトは6分であるため、ダウンロードはタイミングアウトです。タイムアウト値は、WEBUI サービスが特定の接続によって縛られたリソースを保持しないようにし、WEBUI または CLI を使用して構成することができないようにします。
解決方法
この回避策は、SCP または FTP 経由でスケジュールされたログエクスポートを使用することです。または、"CSV エクスポートの最大行数" の値 (デフォルトは 65535) を小さくして、ファイルのサイズを ower し、ダウンロードが6分以内に完了する確率を上げることができます。
所有者: jlunario