Exportar registros de tráfico CSV no se puede descargar completamente en el Firewall de la serie PA-2000

Exportar registros de tráfico CSV no se puede descargar completamente en el Firewall de la serie PA-2000

35022
Created On 09/26/18 13:54 PM - Last Modified 06/09/23 06:32 AM


Resolution


Incidencia

La exportación CSV de registros de tráfico de la interfaz de usuario Web en un cortafuegos de la serie PA-2000 no se descarga completamente cuando las filas máximas en el valor de exportación de CSV se establecen en el máximo (1048576). Los archivos de registro de tráfico normalmente serán mayores que 300MB, pero el archivo descargado sólo contiene una fracción de los datos totales.

Nota: este comportamiento sólo es aparente en los cortafuegos de la serie PA-2000.

Las filas máximas en el valor de exportación CSV están configuradas en: dispositivo > configuración > administración > configuración de registro y reporting.

X. png

Independientemente del navegador web, la descarga seguirá siendo de tiempo de espera. IE muestra el error, "log. csv la descarga fue interrumpida". En Firefox, no hay ningún error, pero la barra de descarga se cerrará como si no se ha producido ningún problema.

No hay un umbral exacto para las "filas máximas en la exportación CSV" en las que se producirá el problema. Los factores que definen son el tamaño del archivo CSV y el ancho de banda de la conexión para recuperarlo. Hacer que el valor de "filas máximas en la exportación CSV" a la entrada máxima de 1048576 producirá un archivo CSV mayor que 300MB, por lo que tardará más tiempo en descargarse. Si la descarga tarda más de 6 minutos, el archivo CSV descargado sólo será una parte del archivo CSV general. Si el cliente que descarga el archivo es de un sitio remoto con una conexión lenta, el archivo descargado será menor debido al tiempo de espera de 6 minutos.

Causa

La descarga se está agotando porque el tiempo de espera del servicio WebUI en el cortafuegos de Palo Alto Networks es de 6 minutos. El valor de tiempo de espera impide que el servicio WebUI Mantenga los recursos atados por una conexión concreta y no se puede configurar a través de WebUI o CLI.

Resolución

La solución es utilizar la exportación de registro programado a través de SCP o FTP. O, el valor (por defecto es 65535) de "Max filas en CSV Export" puede ser disminuido al tamaño del archivo y aumentar la probabilidad de que la descarga se complete en 6 minutos.

Propietario: jlunario



Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000ClyyCAC&lang=es&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language