A Long User Activity Report does not Show All Data
19367
Created On 09/26/18 13:53 PM - Last Modified 04/22/21 21:04 PM
Symptom
A User Activity Report for a highly active user over a thirty-day period does not show all the data for the specified time period.
Environment
- Palo Alto Firewall or Panorama.
- PAN-OS 8.1 and above.
- User Activity Report.
Cause
By default, the User Activity logs are limited to 5000 URL log entries.
Resolution
Increase the User Activity report from the default of 5000 to a higher value. The maximum is now 1048576 URL long entries.
- To change the default setting use GUI: Device > Setup > Management > Logging and Reporting Settings > Log Export and Reporting > Maximum Rows in User Activity report and change the value to desired value (less than 1048576).
- Commit the changes.
Note: For Panorama the setting can be changed at GUI: Panorama > Setup > Management > Logging and Reporting Settings > Log Export and Reporting > Maximum Rows in User Activity report
Additional Information
To change the default setting via CLI, go to configuration mode and enter the following command with the desired value:
> configure
# set device config setting management max-rows-in-pdf-report <value>
# commit
# exit