Device is Not Responding to SNMP Polls
97026
Created On 09/26/18 13:50 PM - Last Modified 01/23/24 03:24 AM
Symptom
- SNMP enabled on Palo Alto Firewall.
- The interface is not responding to SNMP requests.
- Monitoring the SNMP log using ">tail follow yes mp-log snmpd.log"display error message.
> tail follow yes mp-log snmpd.log
iquerySecName has not been configured - internal queries will fail
NET-SNMP version 5.4.4
Received TERM or STOP signal... shutting down...
- Restarting SNMP using the CLI command "> debug software restart process snmpd" does not help
Environment
- Palo Alto Firewall
- Supported PAN-OS
- SNMP
Cause
- SNMP version1 configured which is not supported on Palo Alto Firewalls.
- This can be verified by capturing tcpdump on the management interface
Simple Network Management Protocol
version: version-1 (0)
community: pantest
data: get-request (0)
Resolution
- Palo Alto Networks firewall supports SNMPv2c and SNMPv3.
- Ensure that the SNMP manager does not use SNMPv1.