Delay in Connections Using GlobalProtect
Symptom
When the user right-clicks on the GlobalProtect icon and chooses "connect", it can take up to 15 seconds before the login box appears. Once the user logs in, another 30-45 seconds may pass before the client connects. This issue is only occurrs on certain clients, even if all the clients run the same Windows image and GlobalProtect Client version.
Environment
- GlobalProtect Agent
- GlobalProtect Portal and/or Gateway
- Windows OS
Cause
It has been observed that the connection is instant if the user unchecks the "Automatically Detect Settings" for the proxy option under Internet Explorer. Even if the user does not have a proxy server, the proxy settings may be set in Internet Explorer. This is where the issue resides and the reason why some clients exhibit the problem (where the proxy settings are set).
When reviewing the GlobalProtect client logs, the user might see:
(T2760) 12/09/13 09:43:16:863 Debug (4651): Auto detect proxy for host vpn.domain.com
(T2760) 12/09/13 09:43:37:908 Debug(4662): CPanMSService::SetProxyForHost:
fAutoDetect: 1 url: proxy: bypass: url: https://vpn.domain.com/ returned proxystr:
In the example above, it takes 31 seconds for the Windows system to detect the proxy setting. The result is no proxy for https://vpn.domain.com/, even if the url is opened.