Globalprotect Agent preLogon scheitert auch nach dem Import privater PKI-Zertifikate
Resolution
Problem
Der globalprotect Agent preLogon scheitert auch dann, wenn der Kunde private PKI-Zertifikate manuell auf dem lokalen Zertifikats Lager importiert.
Der Versuch, den globalprotect Agent preLogon zu verbinden, wird sich aufgrund des folgenden Fehlers nicht verbinden:
(T2796) 06/19/14 10:52:15:442 Debug (3233): Es ist nicht gelungen, sich dem Portal vorzuloggen <GATEWAY-IP-ADDRESS>.</GATEWAY-IP-ADDRESS> Fehler 12186
Ursache
Das Problem kann dadurch verursacht werden, dass die privaten PKI-Zertifikate manuell in Drag and Drop-Manier importiert werden.
Zum Beispiel auf der Microsoft Management Console (MMC):
- Drag and Drop Machine-Zertifikat an Local-Computer > Personal > Zertifikate
- Drag and Drop Root-CA-Zertifikat an aktuelle Benutzer > vertrauenswürdige Root-Zertifizierungsbehörden > Zertifikate
- Root-CA-Certificate auf Local-Computer > vertrauenswürdige Root-Zertifizierungsbehörden > Zertifikate kopieren und Einfügen
Beim manuellen ziehen und Ablegen von Zertifikaten können einige Zertifikats Attribute/Felder fehlen. Daher ist dies kein empfohlenes Verfahren zur Installation von Zertifikaten.
Lösung
Der richtige Weg, Zertifikate zu importieren, ist entweder durch ein GPO-Installations Zertifikat oder ein manuelles Installations Zertifikat.
Das folgende Beispiel ist von einer Windows7-Maschine:
- Löschen Sie das vorherige fehlerhafte Maschinen Zertifikat und das Root-CA-Zertifikat auf MMC.
- Rechtsklick lokal-Computer > Personal > Zertifikate, alle Aufgaben > importieren, Import des Maschinen Zertifikats.
- Mit der rechten Maustaste auf den Strom-Benutzer > vertrauenswürdige Root-Zertifizierungsstellen > Zertifikate, alle Aufgaben > importieren, importieren Sie das Root-CA-Zertifikat.
- Klicken Sie mit der rechten Maustaste auf Local-Computer > vertrauenswürdige Root-Zertifizierungsstellen > Zertifikate, alle Aufgaben > importieren, importieren Sie das Root-CA-Zertifikat.
- Deinstallation globalprotect Agent.
- Globalprotect Agent neu installieren, globalprotect und Connect neu konfigurieren.
Besitzer: Jlunario