Problem
Agenten werden nicht automatisch aktualisiert, auch wenn Portal Client config so eingestellt ist, dass Nutzer im transparenten Modus automatisch aktualisiert werden.
Der transparente Modus ist mit folgenden Schritten aktiviert:
- Navigieren Sie zum Netzwerk > globalprotect > Gateway config > Agent
- Wählen Sie im Bereich Agent Configuration den transparenten Modus für das Client-Upgrade
Client Upgrade Modes:
- Prompt-dieser Modus veranlasst den Client, nach Konfigurationsänderungen zu aktualisieren.
- Transparent-dieser Modus führt das Upgrade lautlos ohne Benutzer Aufforderung durch.
Ursache
Stellen Sie sicher, dass der Benutzer nicht erwartet, dass der Upgrade-Prozess stattfinden wird, bevor der globalprotect-Client mit seinem Netzwerk verbunden ist. Dieses Upgrade wird erst dann stattfinden, wenn die Verbindung zu seinem Netzwerk hergestellt wurde, um Produktivitätseinbußen für den Endverbraucher zu vermeiden. Nachdem die Verbindung hergestellt wurde, wird dann die Aufgabe begonnen, das Upgrade automatisch und transparent im Hintergrund herunterzuladen. Nach der Installation der neuen Version kann die Verbindung fallen und sich wieder verbinden, um die Verbindung mit der neuen Client-Version herzustellen. Überprüfen Sie auch, ob die Nutzer einen hohen Traffic in Ihrem Netzwerk erleben. Wenn es eine hohe Verkehrssituation gibt, könnten einige Kunden das Paket nicht herunterladen. Globalprotect verzögert die Aufgabe um ein zufällig bestimmtes Intervall (1 bis 30 Minuten). Es gibt keine Garantie dafür, dass jeder Download das erste Mal erfolgreich sein wird, aber es wird irgendwann gelingen.
Das automatische Update hängt auch davon ab, welche vorherige Version installiert wurde. Wenn es sich um eine ältere Version handelt, können einige vorhandene Informationen nicht weitergeführt worden sein.
Hinweis: nach globalprotect Agent 2.0.1 konnte der vorhandene Wert weitergeführt werden und es besteht keine Notwendigkeit für eine manuelle Aktualisierung.
Besitzer: bsyeda