GlobalProtect Fordert Systemschlüsselbundzugriff auf OS X Mac-Clients an

GlobalProtect Fordert Systemschlüsselbundzugriff auf OS X Mac-Clients an

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Created On 09/25/18 20:40 PM - Last Modified 08/15/22 22:57 PM


Symptom


  • Die Computerzertifikatauthentifizierung wird auf MAC OS X Clients verwendet. Während des GlobalProtect Verbindungsvorgangs muss der Benutzer die Anmeldeinformationen des lokalen Administrators-Kontos eingeben, um den Zugriff auf den Systemschlüsselbund zweimal zu ermöglichen.



Environment


  • Vorhandene GlobalProtect Infrastruktur
  • macOS-Endpunkte


Cause


  • Wenn Sie Computerzertifikate mit GlobalProtect Mac OS X Clients verwenden, muss auf das Zertifikat über den Schlüsselbund "System" in zugegriffen MAC OS X werden.Dies führt dazu, dass eine Eingabeaufforderung für den Schlüsselbundzugriff zweimal angezeigt wird, wenn der Client versucht, auf das Zertifikat zur Überprüfung sowohl für das Portal als auch für das Gateway zuzugreifen.



Resolution


 

Als Problemumgehung können Sie die folgenden Schritte implementieren:

  1. Öffnen Sie die Keychain Access-Anwendung, und suchen Sie das Computerzertifikat, das dem Mac OS X Client ausgestellt wurde, im Systemschlüsselbund.
  2. Klicken Sie mit der rechten Maustaste auf den privaten Schlüssel, der dem Zertifikat zugeordnet ist, und klicken Sie auf Informationen abrufen, und gehen Sie dann zur Registerkarte Zugriffssteuerung
  3. Klicken Sie auf "+", um eine Anwendung auszuwählen, damit
  4. Drücken Sie die Tastenkombination <Command>+ <Shift> G +, um zum Ordner zu öffnen</Shift> </Command>
  5. Geben Sie '/Applications/ GlobalProtect .app/Contents/Resources' ein und klicken Sie auf Gehe
  6. Suchen Sie PanGPS, und klicken Sie darauf, und drücken Sie dann Add
  7. Änderungen an privaten Schlüssel speichern

 

Hinweis: Die obigen Schritte ermöglichen GlobalProtect den Zugriff auf nur Zertifikat und privaten THIS Schlüssel.Es wird nicht mehr für Schlüsselbund-Zugriff, so dass Benutzer eine nahtlose, No-Touch-Erfahrung mit Palo Alto Networks GlobalProtect .

Hinweis: Wenn die oben angegebene Problemumgehung nicht funktioniert, gehen Sie bitte wie aus folgenden Arbeiten aus:

  1. Verschieben des Zertifikats aus dem Systemschlüsselbund in den Anmeldeschlüssel
  2. Schritt 1 sollte dann eine Eingabeaufforderung ähnlich wie unten erstellen.Klicken Sie auf "Immer zulassen"

Benutzeriertes Bild

  • Das Verfahren muss jedes Mal wieder durchgeführt werden, wenn der Kunde aktualisiert wird.

 



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