Aucune Page de blocage de logiciels malveillants lorsque vous utilisez le décryptage SSL

Aucune Page de blocage de logiciels malveillants lorsque vous utilisez le décryptage SSL

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Created On 09/25/18 19:30 PM - Last Modified 06/14/23 07:32 AM


Resolution


Symptôme

Lors de l’utilisation politique de décryptage SSL pour bloquer les logiciels malveillants, la page de blocage n’affiche pas toujours.

Cause

Lorsque vous demandez une page web, les navigateurs ont tendance à permettre toute réponse avec un en-tête similaire à ceci :

Accepter : text/html, image/png, */*;q=0.1\r\n

Le * / * indique toute réponse sera acceptée.

Lorsque vous demandez un objet spécifique (.zip, .txt, etc.) le navigateur client peut autoriser uniquement ce type de réponse, en limitant ce que le navigateur affichera. Si la demande d’un fichier .txt, vous ne pouvez voir :

Accepter : texte/text\r\n

Lorsque le pare-feu s’affiche une page de réponse indiquant que la demande est bloquée à cause d’un virus, il l’affiche comme une page html. Le type mime est text/html. Cela peut signifier que si le navigateur permet uniquement de texte/texte, la page s’affichera pas.

Lors d’une communication SSL, le navigateur client peut fermer la demande plutôt que d’afficher une erreur qui le type mime ne correspond pas à ce qui était demandé. Cela se traduit par le navigateur juste « spinning », n’affichant pas n’importe quelle page, jusqu'à ce qu’une erreur s’affiche après un délai d’attente.

propriétaire : gwesson



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