Palo Alto Networks Knowledgebase: Reports from Email Scheduler Appear Different from WebGUI Reports

Reports from Email Scheduler Appear Different from WebGUI Reports

2521
Created On 02/07/19 23:49 PM - Last Updated 02/07/19 23:50 PM
Reporting and Logging
Resolution

Issue

When a Custom Report is scheduled through the Email Scheduler, it appears to be different than a report generated from the WebGUI.

 

Shown below are two Custom Report examples, (Monitor > PDF Reports > Custom Reports):

CR1.JPGCR2.JPG

 

See the Report Group below (Monitor > PDF Reports > Report Group):

RG.JPG

 

There is a Email Scheduler sending the reports from this Report Group (Monitor > PDF Reports > Email Scheduler):

ES.JPG

 

The Custom Report generated from the WebGUI looks like this:

CR_GUI.JPG

 

The Custom Report sent from the Email Scheduler looks like this:

CR_ES.JPG

 

The report generated from the WebGUI appears as expected, but the report from the Email Scheduler is missing some data and does not appear the same.

 

Cause

When configuring the Report Group, there are 2 options to choose a report from. One is under the "custom report" tree and the other is from the "log view" tree.

If "custom report" tree is selected only the report will be sent without all of the log data.

If "log view" tree is selected, all logs corresponding to the report will be sent in the pdf report.

custom log report.pngReport Group detail, showing the Custom Report and Log View options.

 

Resolution

In order to display all of the data from the logs in the Emailed Reports, go to Monitor > PDF Reports > Report Groups and select the report from under the "Log View" tree instead from under Custom Report.

 

Note: Panorama does not include the "Log View" option, so you will have to rely on the reports from the Firewall directly if you would like this data.

 

owner: achalla



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