Commit Error: Duplicate User Name - Failed to parse security policy

Commit Error: Duplicate User Name - Failed to parse security policy

15116
Created On 09/25/18 18:47 PM - Last Modified 06/08/23 07:03 AM


Resolution


Issue

The following error occurs when committing changes to a configuration:

Error:Duplicate user name 'intranet\USER01'
Error:Failed to parse security policy
(Module:device)
commit failed

 

Cause

This error is actually not due to a duplicate user name. Instead, the problem is caused by the name "USER01" in all capitalized (upper case) letters. There are issues when capital letters are used as part of the domain or names in the user fields. When a capitalized name is parsed, the system may consider it a "Duplicate object" when it is not.

 

Resolution

Make sure that all usernames or domains are in lower case for the User field and the commit error should no longer appear.

For example:

  • The value 'intranet\USER01' will return an error.
  • The value 'intranet\user01' will work as expected and commit without issues.

 

owner: jdelio



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