Cannot Log into ESM Console: Could not load file or assembly 'System.Core"
Symptom
Issue
Cannot log into the ESM Console.
Symptom
When trying to log into the ESM console (https:/<server>/EndpointSecurityManager/Account/Login), the following error message appears:
Server Error in '/CyveraManagement' Application.
Could not load file or assembly 'System.Core, Version=2.0.5.0, Culture=neutral,
PublicKeyToken=7c3c85d7bea7798e, Retargetable=Yes' or one of its dependencies. The given
assembly name or codebase was invalid. (Exception fro HRESULT: 0x80131047)
Cause
While .Net 4.0 was installed, the .Net update KB2468871 was not installed.
Resolution
Resolution
Running NDP40-KB2468871-v2-x64.exe from the prerequisite kit followed by an "iisreset" command in the command line.
The exe is downloadable from here: http://www.microsoft.com/en-us/download/details.aspx?id=3556.
If this does not resolve the issue, run "aspnet_regiis.exe –iru" from C:\Windows\Microsoft.NET\Framework64\v4.0.30319