Duplicate Node Error when Pushing Policy from Panorama

Duplicate Node Error when Pushing Policy from Panorama

21155
Created On 09/25/18 17:51 PM - Last Modified 06/09/23 06:03 AM


Resolution


Symptoms

The following error occurs when attempting to push a policy from Panorama to managed Palo Alto Networks devices:

Mar 29 14:45:34 Error: _pan_schema_verify_node(pan_schema_obj.c:3785): is a duplicate node near line 38

<errors>

<line><![CDATA[avg-panorama-object-counts is a duplicate node]]></line>

</errors>

Another possible symptom would be that commit failures from the GUI and CLI with an error referencing a configuration parameter and "duplicate node."  If devices are managed, commits from Panorama may fail with an error similar to the following:

Server error : setting -> custom-logo is a duplicate node

Cause

This can occur when firewalls are upgraded or downgraded to different versions of PAN-OS, and the differences in various versions of code can cause config parsing errors.

Resolution

  1. From Device > Setup > Operations, click Save a named configuration snapshot
  2. From the same page, reload the configured saved in step 1 (duplicate note warnings will occur, this is normal)
  3. From Panorama, push the configuration to the device group

save-named-config-snapshot.JPG

owner: kadak



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