Custom Report Not Included in PDF Summary if 'Scheduled' Option Unchecked

Custom Report Not Included in PDF Summary if 'Scheduled' Option Unchecked

20472
Created On 09/25/18 17:42 PM - Last Modified 06/12/23 18:06 PM


Symptom


Symptoms

 Custom Reports that have the Scheduled option unchecked cannot be included in the PDF Summary Report.

 

For example:

Create a custom report under Monitor > Manage Custom Reports with the Scheduled option unchecked.

 

original.png

 

Next, create another custom report with the Scheduled option checked.

 

original (1).png

 

In the PDF summary report, only the Custom Report with the Scheduled option enabled can be selected.

 

original (2).png

 

 

Diagnosis

 

When the Scheduled option is enabled, the report runs automatically every night at 2 AM device time. When the Scheduled option is unchecked, the Custom Report does not run automatically, so there's no current data to generate a PDF summary.

 

Without a PDF summary, the Custom Report with the Scheduled option unchecked doesn't produce a report to select from the summary PDF Report list.



Resolution


 

Enable the Scheduled option when the Custom Report needs to be included in the PDF Summary Report.

 

Also note that when Last Calendar Week and Last Calendar Month are selected in the Time Frame option, Custom Report cannot be included in the PDF summary because Last Calendar Week and Last Calendar Month reports run only once a week or month and aren't considered appropriate for the PDF Summary Report, which should contain current data.

 

So make sure the Scheduled option is enabled and the options Last Calendar Week and Last Calendar Month are not selected in the Time Frame to include the Custom report in the PDF summary. 



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